New! – Get the brand new version MultilingualPress 3.3

Requirements – What do I need to get MultilingualPress running smoothly?

This tutorial is part of our MultilingualPress 2 documentation. In case you are using the newer version 3, please switch to MultilingualPress 3.

To have MultilingualPress running smoothly on your website, it should meet the following requirements:

  • WordPress as multi-site, at least Version 4.2.
  • at least PHP 5.4.0. Newer versions are faster.

MultilingualPress cannot be used in a single-site WordPress installation. You need to have a multi-site installed. See our tutorial How to install multi-site.


Build the perfect multilingual webshop with WooCommerce and our plugins MultilingualPress and OneStock!